Aktuelle Zeit: 24. Jul 2014, 19:01

[gelöst] Surfstick unter openSUSE 12.2

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

[gelöst] Surfstick unter openSUSE 12.2

Beitragvon HBrink » 1. Okt 2012, 20:05

Mein Rechner geht ausschließlich mit einem Surfstick ins Internet. Das funktionierte mit openSUSE 12.1 einwandfrei, aber seit dem Update auf 12.2 scheint der Stick nicht mehr richtig eingebunden zu werden.

Surfstick ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem

Kernel: Linux 3.4.6-2.10-desktop i686
Distribution: openSUSE 12.2 (i586)
KDE: 4.8.4 (4.8.4) "release 2"

Mein Linux-Level: Vollpfosten
Deshalb bitte ich jetzt um kompetente Hilfe.


Symptomatik / Ablauf

Nach dem Einstöpseln blinkt der Stick grün.
In der Kontrollleiste erscheint der Networkmanager.
Anzeige beim Mouseover: Mobiles Breitband – Nicht verbunden.
Soweit alles normal.

Der Klick auf das Kontrollleisten-Icon öffnet das Fenster mit den Verbindungen.
Screenshot: Das Häkchen bei Mobile Breitbandverbindungen aktivieren ist ausgegraut. Es erscheint nur, wenn die Maustaste gedrückt gehalten wird und verschwindet beim Loslassen.
Der Klick auf den Verbindungsnamem Medion sollte die Verbindung starten.
Statt dessen erscheinen unter Mobiles Breitband in schneller Folge die Meldungen
Authorisierung wird vorbereitet
Verbindung wird vorbereitet
Nicht verbunden


Es folgt die Benachrichtigung in der Kontrollleiste Verbindung mit Medion fehlgeschlagen.

Meldungen aus var/log/messages beim Einstöpseln des Surfsticks
Meldungen aus var/log/messages beim Verbindungsaufbau
Output von collectNWData


Meine Fragen sind nun:
Warum kann ich keine Internetverbindung herstellen?
Wie kann ich das ändern?
Was musst du noch wissen, um mir helfen zu können?


Bisherige erfolglose Ansätze

Anleitungen aus:
http://wiki.ubuntuusers.de/USB_ModeSwitch
http://linux.frankenberger.at/Huawei_E220.html
und was Google sonst noch so ausspuckt.

Hochfahren mit eingestecktem Stick: Häkchen Mobile Breitbandverbindung aktivieren ist manchmal automatisch gesetzt, lässt sich aber nach Entfernen nicht erneut setzen (wieder grau).

Hochfahren / Anmelden mit Failsafe

Eigenschaften der Verbindung ändern:
Verbindung als Systemverbindung einrichten
Häkchen PPP > Authentifizierung setzen
(und einige andere)

Einloggen als root und alles nochmal probieren.


Vielen Dank schonmal an alle, die bis hierhin gelesen haben.
Zuletzt geändert von HBrink am 9. Okt 2012, 15:41, insgesamt 1-mal geändert.
Benutzeravatar
HBrink
Newbie
Newbie
 
Beiträge: 6
Registriert: 1. Okt 2012, 19:01

Re: Surfstick unter openSUSE 12.2

Beitragvon RME » 2. Okt 2012, 01:03

Hallo,

Hilft evtl. folgendes...

Mobiles Breitband startet nicht automatisch
http://www.opensuse-forum.de/mobiles-breitband-startet-nicht-automatisch-netzwerk-internet/themen-f9/t7644-f14/
(Post #7)

Von hier:
How do I permanently enable mobile broadband on boot?
http://askubuntu.com/questions/82255/how-do-i-permanently-enable-mobile-broadband-on-boot
sowie:
Enable mobile broadband" option gets unchecked
https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/874900

Gruss,
Roland
Benutzeravatar
RME
Advanced Hacker
Advanced Hacker
 
Beiträge: 1405
Registriert: 27. Sep 2010, 20:32

Re: Surfstick unter openSUSE 12.2

Beitragvon HBrink » 2. Okt 2012, 11:17

Hallo Roland,
vielen Dank für deine Antwort.

Leider bringt das keine Verbesserung.

Konsolen-Ouput:
> nmcli con up id Medion
Status der aktiven Verbindung: wird aktiviert
Pfad der aktiven Verbindung: /org/freedesktop/NetworkManager/ActiveConnection/1
Status: unbekannt
Fehler: Aktivierung der Verbindung ist gescheitert.
>


Gruß,

Henning
Benutzeravatar
HBrink
Newbie
Newbie
 
Beiträge: 6
Registriert: 1. Okt 2012, 19:01

Re: Surfstick unter openSUSE 12.2

Beitragvon spoensche » 2. Okt 2012, 15:50

Du musst wie unter http://www.linupedia.org/opensuse/O2_Surf_Stick beschrieben vorgehen. Der Wiki Artikel bezieht sich auf ein anderes Huawei Modem und du musst die Produkt- und Vendor ID an deine gegebenheiten anpassen.
spoensche
Moderator
Moderator
 
Beiträge: 6647
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Surfstick unter openSUSE 12.2

Beitragvon HBrink » 4. Okt 2012, 14:21

Hallo zusammen,

und Danke für euer Interesse.

Ich habe nun einige Tipps und Anleitungen nachvollzogen.
So auch die Methode mit ifup und umtsmon. Leider erfolglos.
Ich bin mir ziemlich sicher, dass meine Try-&-Error-Strategie einigen Leuten Gänsehaut macht.

Aber ich bekomme nun andere Meldungen in var/log/messages.


Ablauf

Hochfahren mit eingestecktem Stick: Das Häkchen Mobile Breitbandverbindung aktivieren im Verbindungsmanager ist automatisch gesetzt.
Der Stick blinkt grün (für ein gefundenes GPRS-Netz).

Der Versuch eine Verbindung aufzubauen
liefert diese Meldungen in var/log/messages (aber keine Verbindung).

Beim Entfernen des Häkchens folgen diese Meldungen.
Schnittstelle und Verbindung verschwinden aus dem Verbindungsmanager.

Wenig später wird der Stick neu erkannt. Im Verbindungsmanager erscheinen erneut die Schnittstelle Mobiles Breitband und die Verbindung Medion.
Der Stick blinkt blau (für ein gefundenes UMTS-Netz).
Das Häkchen ist nicht gesetzt.

Dann versuche ich vergebens, das Häkchen neu zu setzen. Meldungen.

Abziehen des Sticks: Meldungen

Wieder Einstöpseln: Meldungen
Grünes Blinken.
Häkchen lässt sich nicht setzen.


Fragen

Was kann ich tun, um diesen Stick zum Laufen zu bringen?
Welche Fehlerquellen sollte ich überprüfen?
Was fällt dir sonst noch ein?


Gruß,

Henning
Benutzeravatar
HBrink
Newbie
Newbie
 
Beiträge: 6
Registriert: 1. Okt 2012, 19:01

Re: Surfstick unter openSUSE 12.2

Beitragvon spoensche » 4. Okt 2012, 14:40

Wenn du ifup und UMTS Mon verwendest, dann darfst du nicht den Network Manager verwenden.
spoensche
Moderator
Moderator
 
Beiträge: 6647
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Surfstick unter openSUSE 12.2

Beitragvon HBrink » 7. Okt 2012, 22:09

Hallo spoensche,
wenn ich mich recht entsinne, schliessen ifup und Networkmanager sich aus.
Funktionierte eh nicht.

@all
Ich habe inzwischen auf meinem Daddel-PC openSUSE 12.1 installiert, um zu sehen, wo der Unterschied ist. Hier läuft der Surfstick auf Anhieb total geschmeidig, wie's ja auch sein soll.

Beim Einrichten der Verbindung fällt auf, dass ein paar Berechtigungen umgemuddelt werden. Ich schätze, bei meinem 12.2 weicht da was ab.

Ich werde nun also in Systemeinstellungen > Aktionsberechtigungen herumpfuschen und schauen, was passiert.

Natürlich bin ich auch weiterhin für alle Anregungen / Tipps / Kommentare dankbar.

Schönen Rest-Sonntag noch allerseits.


EDIT / Update

Mein Pfusch vom Sonntag hat nichts gebracht.

Dann hatte ich die Faxen dicke:
Ich habe 12.2 als Neuinstallation drübergebraten.
Trotzdem ließ sich die Internetverbindung über den Surfstick nicht starten.

Also habe ich das letzte funktionierende 12.1 aus meinem Backup wiederhergestellt und 12.2 nochmal als Update installiert.
Und dann ging's. Einmal.

Ich werde von meinem eigenen Compi getrollt.

Ich versuche noch, ein Verhaltensmuster zu erkennen.
Im Moment sieht's für mich so aus, dass der Surfstick manchmal funktioniert, wenn er beim Kaltstart eingestöpselt ist.
Benutzeravatar
HBrink
Newbie
Newbie
 
Beiträge: 6
Registriert: 1. Okt 2012, 19:01

Re: Surfstick unter openSUSE 12.2

Beitragvon HBrink » 9. Okt 2012, 15:41

Wenn die Verbindung aufgebaut werden kann, wird nach der PIN zum Entsperren der SIM-Karte gefragt.
Diese PIN-Abfrage kam sonst nicht. Ich denke, dass irgendetwas die PIN-Abfrage be- oder verhindert, so dass die SIM-Karte gesperrt bleibt.
Ich habe auf der SIM-Karte die PIN-Abfrage ausgeschaltet, und siehe da:

Nun geht’s!

Damit ist das eigentliche Problem zwar nur umgangen,
ich markiere den Thread aber trotzdem als
Gelöst
Benutzeravatar
HBrink
Newbie
Newbie
 
Beiträge: 6
Registriert: 1. Okt 2012, 19:01

Re: [gelöst] Surfstick unter openSUSE 12.2

Beitragvon spoensche » 12. Okt 2012, 19:24

Wenn du UMTSmon verwendest, kannst du den Pin für die Sim hinterlegen. Bin mir da allerdings nicht ganz sicher.
spoensche
Moderator
Moderator
 
Beiträge: 6647
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: [gelöst] Surfstick unter openSUSE 12.2

Beitragvon Jägerschlürfer » 13. Okt 2012, 12:27

einfach die PIN Abfrage deaktivieren und man hat keine Probleme mehr. So habe ich das auch gemacht. UMTSmon habe ich schon lange nicht mehr genutzt, da die Verbindung bisher eigentlich immer gut mit dem networkmanager funktioniert hat.
>Linux-Club Foren FAQ< >LC-Wiki< >Paketsuche<

Meine Systeme:
Desktop1: Ubuntu 12.04
Desktop2: Windows 7, Debian, Aptosid, Opensuse
Notebook: Manjaro
Netbook: Linux Mint
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
 
Beiträge: 4031
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: [gelöst] Surfstick unter openSUSE 12.2

Beitragvon HBrink » 16. Okt 2012, 10:41

Hallo spoensche
ich hatte mich mit UMTSmon befasst und die PIN wahrscheinlich auch dort eingetragen.
Hätte das funktioniert, wäre ich wohl dabei geblieben.
Da der Networkmanager aber in 12.1 lief, würde ich den bevorzugen.

Ich bin mir nicht mehr ganz sicher, ob ich die PIN anfangs in KWallet hinterlegt hatte.
Vielleicht hat's auch nichts damit zu tun.
Jedenfalls ist KWallet inzwischen ausgeschaltet und ich will mir nun auch nicht mehr zu viele Gedanken drüber machen.


Hallo Jägerschlürfer
schön zu wissen, dass auch erfahrene User den einfacheren Weg gehen :D


@all
ich habe meine Posts nochmal angeschaut und melde mich nun nochmal für einen Nachtrag:

Die ganze Zeit war ich irritiert von dem fehlenden Häkchen bei Mobile Breitbandverbindung aktivieren.
Es ist noch immer nicht permanent gesetzt, erscheint aber automatisch im Laufe des Verbindungsaufbaus.

Offensichtlich habe ich das überbewertet und hätte mich besser auf andere Symptome konzentriert.
Zuletzt geändert von HBrink am 16. Okt 2012, 20:51, insgesamt 1-mal geändert.
Benutzeravatar
HBrink
Newbie
Newbie
 
Beiträge: 6
Registriert: 1. Okt 2012, 19:01

Re: [gelöst] Surfstick unter openSUSE 12.2

Beitragvon Jägerschlürfer » 16. Okt 2012, 10:55

HBrink hat geschrieben:schön zu wissen, dass auch erfahrene User den einfacheren Weg gehen :D

Naja, wieso sollte man sich das Leben auch schwer machen, wenn es so einfach geht,...
>Linux-Club Foren FAQ< >LC-Wiki< >Paketsuche<

Meine Systeme:
Desktop1: Ubuntu 12.04
Desktop2: Windows 7, Debian, Aptosid, Opensuse
Notebook: Manjaro
Netbook: Linux Mint
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
 
Beiträge: 4031
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg


Zurück zu Internet und Netzwerk

Wer ist online?

Mitglieder in diesem Forum: Exabot [Bot] und 0 Gäste