Aktuelle Zeit: 23. Okt 2014, 03:36

XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon Zettmaster » 2. Okt 2009, 23:09

Hallo Experten!

Is es möglich den Surf-Stick XS Surf W14 unter Suse 11.1 zum laufen zu kriegen?

Stick Hersteller und Produkt ID:
Code: Alles auswählen
vendor=0×1c9e product=0×9603


/etc/usb_modeswitch.conf Eintrag:
Code: Alles auswählen
DefaultVendor= 0x1c9e
DefaultProduct= 0xf000
TargetVendor= 0x1c9e
TargetProduct= 0x9603
MessageEndpoint=0x01
MessageContent="55534243123456788000000080000606f50402527000000000000000000000"


Starten des Sticks mittels:
Code: Alles auswählen
modprobe usbserial vendor=0×1c9e product=0×9603

danach:
Code: Alles auswählen
usb_modeswitch -c /etc/usb_modeswitch.conf

Ausgabe:
Code: Alles auswählen
 
 * usb_modeswitch: tool for controlling "flip flop" mode USB devices
 * Version 1.0.2 (C) Josua Dietze 2009
 * Works with libusb 0.1.12 and probably other versions

Looking for target devices ...
 No devices in target mode or class found
Looking for default devices ...
 Found default devices (1)
Accessing device 006 on bus 002 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 OK, driver found ("dummy")
 OK, driver "dummy" detached

Received inquiry data (detailed identification)
-------------------------
  Vendor String: USBModem
 Product String: Disk
Revision String: 2.31
-------------------------

Device description data (identification)
-------------------------
Manufacturer: USB Modem
     Product: USB Modem
  Serial No.: 1234567890ABCDEF
-------------------------
Setting up communication with interface 0 ...
Trying to send the message to endpoint 0x01 ...
 OK, message successfully sent
-> Run lsusb to note any changes. Bye.


Jetzt findet UMTSMON nach Eingabe der PIN ein o2 gprs Netz...Der Networkmnager 0.9 auch,
nur ppp will einfach nicht.

APN: internet.mobilcom oder surf.mobilcom
Nummer: *99#
Benutzername & Passwort leer gelassen

Umtsmon Requester öffnet sich nach dem ppp Einwahlversuch:
Code: Alles auswählen
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB1
Connection terminated.
Terminating on signal 15
Modem hangup


Was kann das sein? Wer hat den Sick am laufen?

Gruß
Enrico
Zettmaster
Member
Member
 
Beiträge: 94
Registriert: 12. Sep 2004, 10:06
Wohnort: Coswig Anhalt

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon spoensche » 3. Okt 2009, 01:03

Ist bei dir der smpppd installiert?
Code: Alles auswählen
rpm -qa | grep ppp


http://www.linupedia.org/opensuse/O2_Surf_Stick
spoensche
Moderator
Moderator
 
Beiträge: 6736
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon Zettmaster » 3. Okt 2009, 22:54

[quote="spoensche"]Ist bei dir der smpppd installiert?
Code: Alles auswählen
rpm -qa | grep ppp


Code: Alles auswählen
ppp-devel-2.4.5.git-2.18
smpppd-1.59_SVN31-2.5
ppp-2.4.5.git-2.18
ppp-userpass-2008.12.9-1.1
Zettmaster
Member
Member
 
Beiträge: 94
Registriert: 12. Sep 2004, 10:06
Wohnort: Coswig Anhalt

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon spoensche » 7. Okt 2009, 07:40

Die benötigten Pakete sind installiert. Ist dein lokaler Benutzer Mitglied in der Gruppe uucp und dialout? Hast du als User root mit umtsmon ein Verbindungsprofil angelegt?
spoensche
Moderator
Moderator
 
Beiträge: 6736
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon Zettmaster » 7. Okt 2009, 20:56

spoensche hat geschrieben:Die benötigten Pakete sind installiert. Ist dein lokaler Benutzer Mitglied in der Gruppe uucp und dialout? Hast du als User root mit umtsmon ein Verbindungsprofil angelegt?


Hallo,


benutzer ist in den Gruppen eingetragen. Ich habe den Stick mal unter Windows betrieben. Bei den Einstellungen stand O2 Loop...
da muss ich mal abschreiben und probieren. Habe jetzt den Laptop nicht da...kommt erst am WE. Habe auch noch einen Huawei E169 bekommen. Der funzt garantiert...

Ich meld mich,

Danke & bis später
Zettmaster
Member
Member
 
Beiträge: 94
Registriert: 12. Sep 2004, 10:06
Wohnort: Coswig Anhalt

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon noies » 2. Nov 2009, 22:03

Hallo Leute,

also ich habe den gleichen UMTS Stick von Alice und genau dieses Problem.
Habe es auch schon mit dem Networkmanager versucht, der aber leider den Stick erkennt aber nicht unterstützt.
Hast Du schon eine Lösung ?
Könntest Du alle Deine Schritte hier auch noch posten ?

Grüße,
Noies
noies
Newbie
Newbie
 
Beiträge: 2
Registriert: 2. Aug 2005, 11:03

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon Zettmaster » 2. Nov 2009, 23:20

noies hat geschrieben:Hallo Leute,

also ich habe den gleichen UMTS Stick von Alice und genau dieses Problem.
Habe es auch schon mit dem Networkmanager versucht, der aber leider den Stick erkennt aber nicht unterstützt.
Hast Du schon eine Lösung ?
Könntest Du alle Deine Schritte hier auch noch posten ?

Grüße,
Noies


Leider nein...ich habe mir einen Huwai 169 gekauft und geflasht ... Der funktioniert wenigstens....

Irgendwie wird mit Absicht versucht Chipsätzte auf den Massenmarkt zu werfen die ständig geändert werden nur damit sie
unter Linux Systemen nicht funktionieren. Siehe MSI DVB-T Stick miniII V3.0 der über Nacht nur noch mit RTL Chipsatz verkauft wird.

Meine Kunden fühlen sich von der Wirtschaft verarscht. Zum Glück gibts das Rückgaberecht...

Gruß
Enrico
Zettmaster
Member
Member
 
Beiträge: 94
Registriert: 12. Sep 2004, 10:06
Wohnort: Coswig Anhalt

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon whois » 3. Nov 2009, 07:57

Zettmaster hat geschrieben:Meine Kunden fühlen sich von der Wirtschaft verarscht. Zum Glück gibts das Rückgaberecht...

Das ist leider ein Problem mit dem ich auch hin und wieder zu kämpfen habe, alles muss man mühsam einbinden. :/
Benutzeravatar
whois
Administrator
Administrator
 
Beiträge: 16429
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon Jägerschlürfer » 3. Nov 2009, 08:44

man kann aber auch die jeweiligen Firmen vorher mal anschreiben. Meistens bekommt man hier dann auch die Info, was man haben will.

Ich hab mich z.B. auch erst erkundigt, was für ein Stick ich bekomme.
Und dementsprechend hat dann alles ohne Probleme funktioniert.
>Linux-Club Foren FAQ< >LC-Wiki< >Paketsuche<

Meine Systeme:
Desktop1: Ubuntu 12.04
Desktop2: Windows 7, Debian, Aptosid, Opensuse
Notebook: Manjaro
Netbook: Linux Mint
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
 
Beiträge: 4041
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: XS Surf W14 USB-UMTS-Stick o2 Suse 11.1

Beitragvon Zettmaster » 3. Nov 2009, 09:14

Jägerschlürfer hat geschrieben:man kann aber auch die jeweiligen Firmen vorher mal anschreiben. Meistens bekommt man hier dann auch die Info, was man haben will.

Ich hab mich z.B. auch erst erkundigt, was für ein Stick ich bekomme.
Und dementsprechend hat dann alles ohne Probleme funktioniert.


Das Problem ist aber so:

Kunde A kauft DVB-T Stick vor 2 Monaten. Dieser funktioniert mit der AF9015 Firmware beim einstecken. Kunde B kommt zu mir in den Laden. Möchte für Linux (ja, es gibt momentan viiiieeelleee Linux anfragen;) einen DVB-T Stick.
Ich empfehle den Stick den Kunde A erfolgreich in Betrieb hat.
Der Stick hat die selbe Bezeichnung! Das gleiche Aussehen! Also kein Unterschied wenn man beide Sticks nebeneinander legt.

Leider funktioniert der Stick von Kunde B nicht weil der verwendete Chipsatz ohne Vorwarnung geändert wurde.

Gruß
Enrico
Zettmaster
Member
Member
 
Beiträge: 94
Registriert: 12. Sep 2004, 10:06
Wohnort: Coswig Anhalt


Zurück zu Hardware

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste